Gros bug d'affichage Joomla3 en Backend

06 Déc 2016 13:48 #1 par alainD
Bonjour,
Me-revoici. J'ai fait beaucoup de progrès sur Joomla3 mais il m'en reste tellement à faire. Par exemple depuis une demi-heure, j'ai un gros bug d'affichage sur le BackEnd. Il me manque quasiment tout l'écran. J'étais en train de modifier les autorisations des rédacteurs. Après un "Enregistrer et Fermer", j'ai sélectionné le deuxième rédacteur mais la nouvelle fenêtre ne montrait plus en haut ni la barre "Système, Contenus, Extensions", ni lai barre "Enregistrer, Fermer" etc ... Donc pas moyen de sortir de la page, ni du backend car il aurait fallu que je fasse "Fermer" sur cette page. Quand je me reconnecte en backend, j'obtiens la vue suivante

Le site fonctionne normalement en FrontEnd. Je ne sais pas quoi faire avec mon serveur FTP pour rétablir un dialogue normal, ni comment reprendre la main depuis le FrontEnd.
Merci à tous les éclaireurs
Pièces jointes :

Connexion pour participer à la conversation.

08 Déc 2016 10:34 #2 par Simon
Bonjour,

il est probable que les droits et accès des super utilisateurs aient été modifiés.
As-tu une sauvegarde de ce site ?

Élargissons notre vision du web et de ses relations avec Joomla! Cinnk magazine
Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous
Formation Joomla 3 pour débutant : 40 Tutoriels vidéos pour débuter avec Joomla!
Plus de 100 Trucs et Astuces pour Joomla 3
Suivez moi sur Twitter

Connexion pour participer à la conversation.

08 Déc 2016 13:46 #3 par alainD
Simon,
Merci pour votre réponse. Je peux me connecter en BackEnd et me déconnecter sans problème puisque c'est un des rares parties de l'écran qui soit accessible (voir ma recopie d'écran du message précédent). J'ai le sentiment qu'il me faudrait "relancer" Joomla mais où : FTP, DB ? Et tout le FrontEnd fonctionne normalement.
Mon site est chez OVH qui fait les sauvegardes automatiquement. Si vous pensez que c'est la seule solution, je le ferai mais je ne comprends pas quel "événement" peut modifier ainsi l'apparence du BackEnd. Ca ressemble vraiment à un bug d'affichage.
Je vous écoute avec impatience.
Cordialement,
PS : je n'ai pas encore mis au point les sauvegardes/restaurations avec Akeeba cat autant l'archivage parait simple, autant la restauration me parait mystérieuse et confuse. Il faut que je continue à creuser ce point.

Connexion pour participer à la conversation.

08 Déc 2016 14:36 #4 par Simon
Cette page ressemble clairement à un site sur lequel le groupe d'utilisateur "Super utilisateur" n'a plus le niveau d'accès "Spécial".
Il est donc normal de pouvoir se connecter (cela est régler par un droit) et de ne rien avoir d'affiché.

Il est important de faire une sauvegarde avant de toucher au système ACLs de Joomla!.
Il est possible de régler ce problème via phpMyAdmin (après avoir fait une sauvegarde de la base de données) :

Dans phpMyAdmin, se rendre dans la table #__users et noter l'id du super utilisateur.
Dans la table #__user_usergroup_map, repérer user_id avec la même valeur que id, et verifier que le group_id soit bien 8
Dans la talble #__viewlevels Accès Spécial (ordering 2) rules doit être (avec les crochets) [6,3,8]

Élargissons notre vision du web et de ses relations avec Joomla! Cinnk magazine
Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous
Formation Joomla 3 pour débutant : 40 Tutoriels vidéos pour débuter avec Joomla!
Plus de 100 Trucs et Astuces pour Joomla 3
Suivez moi sur Twitter

Connexion pour participer à la conversation.

08 Déc 2016 15:19 #5 par alainD
Simon,
Le Super-User est bien en group_id 8 mais dans la table _viewlevels les Super Users sont en [8] et non pas [6,3,8]. Voir ci-dessous. Dois-je le modifier ? Comment sauvegarder dans ce cas ?


Merci pour votre aide.
Pièces jointes :

Connexion pour participer à la conversation.

12 Déc 2016 08:58 #6 par alainD
UP

Connexion pour participer à la conversation.

Temps de génération de la page : 0.308 secondes

Sur ce site, nous utilisons des cookies.