Helix3 Megamenu : le sous menu ne s'affiche pas

05 Aoû 2015 21:57 #7 par arranoa
fynhooft, mon module de menu Formulaire de contact est deja assigne au lien de menu Contact en position left, car il doit apparaitre a gauche sur la page contact.

Connexion pour participer à la conversation.

06 Aoû 2015 16:14 #8 par fynhooft
Bonjour,

Pourtant quand on regarde le code source de ton site test, on trouve :
<li class="sp-menu-item">
<a href="/">Contact haut</a>
</li>

Cela veut dire que ton lien de menu pointe sur rien !
Vas dans Extensions->Gestion des modules.
Sélectionnes ton module.
Cliques sur l'onglet "Assignation des menus".
Coches le lien de menu que tu viens de créer "Contact haut"

Connexion pour participer à la conversation.

06 Aoû 2015 16:55 #9 par serge
je n'ai vraiment pas reussi à reproduire cela ; sur le site test de notre ami, comme sur un autre site test
aurais tu un lien ?

Connexion pour participer à la conversation.

06 Aoû 2015 17:32 - 06 Aoû 2015 17:33 #10 par arranoa

fynhooft écrit: Bonjour,

Pourtant quand on regarde le code source de ton site test, on trouve :

<li class="sp-menu-item">
<a href="/">Contact haut</a>
</li>

Cela veut dire que ton lien de menu pointe sur rien !
Vas dans Extensions->Gestion des modules.
Sélectionnes ton module.
Cliques sur l'onglet "Assignation des menus".
Coches le lien de menu que tu viens de créer "Contact haut"

C'est pas pareil le fait qu'il ne pointe sur rien et qu'aucun module ne lui soit assigne. Tu peux avoir un lien de menu qui pointe vers quelque chose, mais sans aucun module qui ne lui soit assigne. Dans mon cas, effectivement le lien Contact haut ne pointe vers que dalle. Mais ca doit etre serge quant il a fait des tests (je lui avais fait un compte admin, pour qu'il puisse voir de lui meme) qui a modifie le type de lien de menu. Car au debut Contact haut pointait vers la page avec les formulaires de contact (je viens de lui remmetre le bon type de de lien).

serge écrit: je n'ai vraiment pas reussi à reproduire cela ; sur le site test de notre ami, comme sur un autre site test
aurais tu un lien ?

Un lien vers quoi ??

Connexion pour participer à la conversation.

06 Aoû 2015 17:34 #11 par serge
je demande à fynhooft, qui a réussi a priori, un lien vers le site ou il a reussi

Connexion pour participer à la conversation.

06 Aoû 2015 20:34 #12 par fynhooft
Je suis "atterri" sur ce forum grâce à ce lien : helix-framework.org/just-one-module-as-sub-menu .
L'intitulé de la question était : "just one module as sub menu". J'ai lu et interprété que tu n'arrivais pas à faire un menu quand il n'y avait qu'un unique module.
J'ai donc testé la réalisation d'un menu avec un unique module et j'ai retourné mes résultats.

En relisant tes posts, j'avoue que je ne comprends plus quel est ton problème. Est-ce l'unique module dans un menu, est-ce le formulaire de contact (remarque : je n'ai pas de module "formulaire de contact". J'ai un composant et 4 plug-in dont un ,"utilisateurs - Fiches de contact automatiques", qui est inactivé).
Pourquoi tu as besoin d'un module alors que tu peux faire un type de lien de menu "Fiches de contact" avec 4 choix possible ?

A Serge, pour faire mes tests, j'ai installé, en local, le "quickstart pack helix3" standard. Je n'ai même pas mis la langue française. ... et j'ai testé l'unique module dans un lien de menu.

Connexion pour participer à la conversation.

Temps de génération de la page : 0.147 secondes

Sur ce site, nous utilisons des cookies.