Réglé

08 Mar 2014 20:15 - 22 Mar 2014 10:57 #1 par alcor98
Bonjour,
Je suis dans une impasse dans l'articulation de mes menus. Je fais donc appel à votre aide pour tenter d'en sortir

Je m'explique :
Cas n°1
Quand je navigue dans mon menu du haut, je me retrouve avec mon article que j'ai rattaché à la navigation (via le lien menu article,ça c Nikel). Là où ça ne va plus, c'est quand l'article s’affiche, celui-ci apparait avec un menu d'intégré, ce dont je ne souhaite pas.
J'ai regardé l'assignation des menus dans la partie module menu, puis changé temporairement l'attribution de catégorie de cet article en "non attribué" pour voir si il n'existait pas une relation avec mon problème. Résultat inchangé
A savoir que lorsque je lis le fil de navigation "vous êtes ici" j'ai Menu accueil > le menu que je ne souhaite pas>accueil>le nom de mon article


Cas n°2
J'ai crée un menu avec des liens avec pour certain un rattachement racine et d'autre en tant qu'enfant.
Sous cette forme
Article 1
-Article 2
--Article 3
Article 4
Puis crée mon module menu se rattachant à ces 4 article, le tout en page accueil.
Dans ce module j'ai paramétré de la sorte : Base item "courant" Niveau de départ "1"et dernier niveau "tout" et position 7
J'attends donc de voir l'article 1et 4 et lorsque je clique sur article 1 que je puisse voir apparaitre les articles 2 et 3 en relation avec le parent article 1. Autrement dit un fil d’Ariane
Mais le résultat que j'obtiens et mes 4 articles les uns en dessous des autres.

Merci par avance de vos réponses

Connexion pour participer à la conversation.

09 Mar 2014 19:16 #2 par Simon

Cas n°1
Quand je navigue dans mon menu du haut, je me retrouve avec mon article que j'ai rattaché à la navigation (via le lien menu article,ça c Nikel). Là où ça ne va plus, c'est quand l'article s’affiche, celui-ci apparait avec un menu d'intégré, ce dont je ne souhaite pas.
J'ai regardé l'assignation des menus dans la partie module menu, puis changé temporairement l'attribution de catégorie de cet article en "non attribué" pour voir si il n'existait pas une relation avec mon problème. Résultat inchangé
A savoir que lorsque je lis le fil de navigation "vous êtes ici" j'ai Menu accueil > le menu que je ne souhaite pas>accueil>le nom de mon article

Bonjour,

Est-il possible d'avoir un lien vers le site ?
Sinon, normalement,, il suffit d'éditer le module en question, puis de choisir de ne pas l'afficher sur cet élément de menu.

Cas n°2
J'ai crée un menu avec des liens avec pour certain un rattachement racine et d'autre en tant qu'enfant.
Sous cette forme
Article 1
-Article 2
--Article 3
Article 4
Puis crée mon module menu se rattachant à ces 4 article, le tout en page accueil.
Dans ce module j'ai paramétré de la sorte : Base item "courant" Niveau de départ "1"et dernier niveau "tout" et position 7
J'attends donc de voir l'article 1et 4 et lorsque je clique sur article 1 que je puisse voir apparaitre les articles 2 et 3 en relation avec le parent article 1. Autrement dit un fil d’Ariane
Mais le résultat que j'obtiens et mes 4 articles les uns en dessous des autres.

Pour être sûr de comprendre, le but serait d'avoir un menu avec l'ensemble des liens affiché ?

Élargissons notre vision du web et de ses relations avec Joomla! Cinnk magazine
Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous
Formation Joomla 3 pour débutant : 40 Tutoriels vidéos pour débuter avec Joomla!
Plus de 100 Trucs et Astuces pour Joomla 3
Suivez moi sur Twitter

Connexion pour participer à la conversation.

10 Mar 2014 21:44 #3 par alcor98
Bonsoir Simon,
Merci tout d'abord de votre attention.
Voici quelques fichiers qui vous permettrons de pouvoir m'apporter des éléments de réponses.
Non , mon site n'est pas encore en ligne, il est juste en local (Wamp).
Pour le cas numéro 1 / j'ai assigné mon menu, je pense que c'est lié à l'attribution de la catégorie de mes articles.C'est réglé

Pour le cas numéro 2 / Je cherche à créer un fil d’Ariane.J'ai regardé sur le net, je n'ai pas le module breadcrumb présent lorsque je fais nouveau module.En revanche , je sais qu'il est présent dans le dossier d'installation , il se nomme com.breadcrumb. J'ai donc pris le module fil de navigation et remplacé la position par "breadcrumb" puis fait l'assignation du menu. Est-ce la même fonctionnalité en procédant de la sorte ???
Comment réinstaller se module ???
Le résultat attendu est à moitié rempli , à savoir que quand je clique sur le premier nom du menu, celui s'ouvre mais ne se referme pas.Ceux qui lui sont rattacher restent présents à l'affichage.Tous ces articles appartiennent à la même catégorie.Quand je clique sur le second , les autres se déploient, mon problème et que je n'arrive pas à revenir en arrière.
Je ne sais pas si j'ai été clair.
Autre chose, je suis à la cherche
- de compréhension sur la partie " création de formulaire", je souhaite mettre un menu déroulant pour que les utilisateurs puissent choisir un sujet que j'aurai préalablement défini.
-formulaire de sondage
-analyse des visites en partie administrateur, nbre de personnes qui se sont connectés et qu'ont ils consultés.
Si je peux avoir des orientations la dessus.
Bonne soirée et merci par avance.

Connexion pour participer à la conversation.

10 Mar 2014 21:49 #4 par alcor98
Voici les fichiers

Connexion pour participer à la conversation.

12 Mar 2014 15:26 #5 par alcor98
Je clôture le sujet car j'y suis arrivé à force de persévérance.

Connexion pour participer à la conversation.

Temps de génération de la page : 0.232 secondes

Sur ce site, nous utilisons des cookies.