[Réglé] Comment privatiser totalement un site

27 Jui 2014 09:39 - 30 Jui 2014 03:54 #1 par Antje
Bonjour !
Je débute sur joomla et mon site sous joomla 3.3.1 hébergé chez 1&1 ne doit être entièrement accessible qu'aux seuls utilisateurs enregistrés. J'ai donc placé tous les articles, catégories et modules en accès enregistré et réglé l'accès par défaut sur enregistré dans la configuration. Le module connexion apparaît bien sur toutes les pages et doit permettre aux utilisateurs de se connecter.
Par sécurité j'ai mis un mot de passe sur le répertoire du serveur où se trouve le site en utilisant la fonctionnalité proposée par 1&1. Ceci a généré un fichier .htaccess.
Quand on va sur le site on tombe bien sur la demande utilisateur / mot de passe du répertoire, mais une fois cette barrière franchie le site est en accès libre. Tout se passe comme si le module connexion ne servait plus à rien.
Quelqu'un voit-il pourquoi et comment rétablir l'accès enregistré ?

Question subsidiaire : le fait de mettre un mot de passe sur le répertoire empêche-t-il les robots des moteurs de recherche d'accéder au site ? En effet j'ai mis mon site en no index no follow mais j'ai vu que ce n'était pas efficace à 100%.
Merci d'avance !

Connexion pour participer à la conversation.

27 Jui 2014 10:21 #2 par Simon
Bonjour et bienvenue sur le forum,

Quand on va sur le site on tombe bien sur la demande utilisateur / mot de passe du répertoire, mais une fois cette barrière franchie le site est en accès libre. Tout se passe comme si le module connexion ne servait plus à rien.

Les éléments de menu sont-ils bien réglés sur le bon niveau d'accès ?

Sinon, il y a une autre possibilité :
-Mettre le site hors-ligne
-Créer un groupe d'utilisateur avec le droit d'accéder au site hors ligne
-Attribuer les utilisateurs à ce groupe

Question subsidiaire : le fait de mettre un mot de passe sur le répertoire empêche-t-il les robots des moteurs de recherche d'accéder au site ?

Normalement oui, mais comment a été mis en place ce mot de passe ?

En effet j'ai mis mon site en no index no follow mais j'ai vu que ce n'était pas efficace à 100%.

Les moteurs de recherche peuvent sans aucun problème suivre les liens, même s'ils sont en "no index no follow".

Élargissons notre vision du web et de ses relations avec Joomla! Cinnk magazine
Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous
Formation Joomla 3 pour débutant : 40 Tutoriels vidéos pour débuter avec Joomla!
Plus de 100 Trucs et Astuces pour Joomla 3
Suivez moi sur Twitter
Les utilisateur(s) suivant ont remercié: Antje

Connexion pour participer à la conversation.

27 Jui 2014 12:59 #3 par Antje
Effectivement les liens de menu étaient en accès public, je les ai tous mis en accès enregistré mais cela n'a rien changé, le site est toujours accessible librement dès que l'on a saisi le user/password que j'ai mis sur le répertoire du serveur.
En outre le site est déjà hors-ligne.

Ce user/password a été installé par la fonctionnalité proposée dans l'espace client 1&1.
1&1 prévient que cela crée un fichier .htaccess qui écrasera tout fichier .htaccess présent auparavant.
Voici le contenu du fichier .htaccess qui se trouve actuellement dans ce répertoire (c'est moi qui ai mis les xxxxxxx) :

AuthType Basic
AuthName "Access to /site"
AuthUserFile /kunden/homepages/42/dxxxxxxxxx/htpasswd
Require user xxxxxxx

Cela vous parle ?

Connexion pour participer à la conversation.

28 Jui 2014 08:52 #4 par Antje
Bonjour,
Je pense avoir trouvé mon erreur. Il suffisait de mettre le site en ligne dans les paramètres du site (configuration). En effet il était hors ligne mais accessible au groupe des enregistrés. Et de régler le paramètre groupe des visiteurs sur public dans les paramètres de la gestion des utilisateurs. Il était sur enregistré, de sorte que tout visiteur non authentifié avait automatiquement les droits du groupe enregistré, donc accès libre au site !
Tout fonctionne bien désormais.
Merci encore à Simon pour son aide précieuse.

Connexion pour participer à la conversation.

30 Jui 2014 03:53 #5 par Simon
Parfait si le problème est réglé !
Je passe le post en [Réglé] ;)

Élargissons notre vision du web et de ses relations avec Joomla! Cinnk magazine
Pour apprendre à construire votre site web avec Joomla 3 : Joomla3! Le Livre Pour Tous
Formation Joomla 3 pour débutant : 40 Tutoriels vidéos pour débuter avec Joomla!
Plus de 100 Trucs et Astuces pour Joomla 3
Suivez moi sur Twitter

Connexion pour participer à la conversation.

Temps de génération de la page : 0.129 secondes

Sur ce site, nous utilisons des cookies.