Problème de lien

01 Jui 2017 14:31 #7 par Christian Bardin
C'est normal, cela ajoute à la page en cours le #nos_produits, c'est un comportment normal du html.
pour pallier à cela, met l'adresse totale du site :
bibconsult.microbib.fr/#nos_produits
dans un lien de type URL, cela devrait marcher.
Mais sinon je trouve très perturbant d'avoir un menu qui parait être le menu principal visuellement, mais qui ne dessert que la page d’accueil, et le vrai menu caché derrière le hamburger.
Cela n'engage que moi.

Connexion pour participer à la conversation.

01 Jui 2017 14:37 - 01 Jui 2017 14:38 #8 par Mk17420
Bonjour Christian,
Ca ne fonctionne toujours pas avec : bibconsult.microbib.fr/#nos_produits.
En fait dans mon sidebar ne se trouve que les raccourcis. Tout ce passe sur la page d'accueil et surtout dans le module nos_produits, c'est bien pour cela qu'il doit fonctionner a partir de toutes les vues.
Peut-être vais-je devoir le dupliquer pour le faire s'afficher dans une page unique qui ne servira que pour un résultat à partir de ce menu.
C'est quand même dommage...

Connexion pour participer à la conversation.

01 Jui 2017 14:38 #9 par RobertG

Mk17420 écrit: merci RobertG ,
malheureusement ça ne change rien...
J'avais déjà essayé. J'ai toujours ce 'truc' (page courante) qui ce rajoute devant mon #
En fait j'ai l'impression qu'a partir du moment ou je met # , pour joomla il cherche automatiquement un lien sur la page. Du coup il transforme le lien html à la page sur laquel on ce trouve.
N'y a-t-il pas moyen de désactiver ce script ponctuellement ?

Pourtat, avec Firebug, si je change le lien de "#nos_produits" en "/nos_produits", d'une part je demande qu'on revienne à l'accueil avec "/", d'autre part ça fonctinne alors correctement sur mon écran.
Je me souviens avoir eu le même souci avec une collègue qui utilisait ce type de "one page", et en vérifiant, je vois que certains liens sont écrits "index.php#ancre"

"Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes, il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - Site pro : www.robertg-conseil.fr

Connexion pour participer à la conversation.

01 Jui 2017 14:41 #10 par Mk17420
Si j’enlève le # il ne s'agit plus d'une encre sur une page, mais bien d'une page ce qui n'est pas le cas ici.

Connexion pour participer à la conversation.

01 Jui 2017 14:48 #11 par RobertG
Pardon, c'est "index.php#nos_produits" qu'il faut mettre comme je l'ai dit en fin de message précédent sous forme "index.php#ancre"

"Patience et longueur de temps font plus que force ni que rage..." (La Fontaine : Le Lion et le Rat) - "Il n'y a pas de problèmes, il n'y a que des solutions" (André Gide). MoovJla et LazyDbBackup sur www.joomxtensions.com - FaQ sur www.fontanil.info hébergés chez PHPNET - Site pro : www.robertg-conseil.fr

Connexion pour participer à la conversation.

01 Jui 2017 14:54 - 01 Jui 2017 14:57 #12 par Mk17420
ca ne fonctionne pas non plus :-(
J'ai créé un doublon de mon module sur le template associé mais ca n'est pas pratique du tout en fait. Et je me retrouve de fait avec le même problème pour le lien services ...
Il faudrait pourvoir écrire un lien http dans l'url externe de joomla sans que celui-ci n'associe systématique un # à un lien de la page en cour et n'ajoute tout seul le nom de la page devant le #

Connexion pour participer à la conversation.

Temps de génération de la page : 0.133 secondes

Sur ce site, nous utilisons des cookies.