[Réglé] Réécriture d'URL ne fonctionne pas en local

21 Nov 2014 17:37 - 19 Mai 2015 15:26 #1 par oliviermireille
Bonjour,

J'ai restauré en local (avec akeeba) une installation qui fonctionne bien (hébergé chez ovh):

Joomla 3.3.6
Apache 2.4.9
PHP 5.5.12

Réécriture d'URL en clair est à OUI

Pas de problème si 'réécriture au vol des URL' est à NON. Tout roule.

Si je passe 'Réécriture au vol d'URL 'à OUI (et que je renomme alors mon htaccess.txt en .htaccess) je n'ai accès qu'à la page d'accueil. Tout accès à un menu me retourne un HTTP 404.

J'ai compris (ou je crois avoir compris) qu'il fallait modifier des entrées dans le .htaccess mais je n'ai pas réussi :-(

Merci

Connexion pour participer à la conversation.

22 Nov 2014 14:04 #2 par LDkwk
Bonjour Olivier,
Même problème pour moi, cela ne marche pas en local, mais cela marche, si le site est placé chez un hébergeur, les index.php? disparaissent.

Cordialement,
LD.

Connexion pour participer à la conversation.

11 Déc 2014 11:38 #3 par informaticien51
essayez de decommenter la ligne rewrite base de votre fichier.htaccess.

Seconde solution, l activer dans le fichier httpd.conf, vu que vous y avez acces.
Les utilisateur(s) suivant ont remercié: LDkwk

Connexion pour participer à la conversation.

15 Déc 2014 16:27 #4 par LDkwk
Bonjour,
la première solution ne marche pas.
(J'utilise MAMP sous Yosemite).

Seconde solution, l activer dans le fichier httpd.conf, vu que vous y avez acces.


J'ai effectivement accès à httpd.conf mais que faire pour l'activer ?

Cordialement,
LD.

Connexion pour participer à la conversation.

17 Déc 2014 08:48 - 17 Déc 2014 08:51 #5 par informaticien51
ton site est à la racine de ton serveur? ou est il dans un sous dossier ?
deux liens utiles pour la réecriture d'url :
httpd.apache.org/docs/current/fr/mod/mod_rewrite.html
forum.alsacreations.com/topic-20-61464-1...teBase-HTACCESS.html
Les utilisateur(s) suivant ont remercié: LDkwk

Connexion pour participer à la conversation.

17 Déc 2014 10:22 #6 par LDkwk
Merci, je regarde ces liens.

Pour info,
mes sites en local sont stockés ainsi :

Macintosh HD ▸ Applications ▸ MAMP ▸ htdocs ▸ sitelocal1
Macintosh HD ▸ Applications ▸ MAMP ▸ htdocs ▸ sitelocal2
...

et le htppd.conf ici :

Macintosh HD ▸ Applications ▸ MAMP ▸ conf ▸ apache ▸ httpd.conf

Connexion pour participer à la conversation.

Temps de génération de la page : 0.204 secondes

Sur ce site, nous utilisons des cookies.