Ajouter un Super Utilisateur via phpMyAdmin

Suite à une mauvaise manipulation (perte de l'accès à votre administration), vous pouvez être amené à ajouter un Super Utilisateur via phpMyAdmin. Voici comment :

 

Connectez vous à phpMyAdmin et sélectionnez votre base de données.

Cliquez sur le bouton "SQL" :

ajouter-admin1

L'écran suivant s'affiche :

ajouter-admin2

Supprimez tout le texte qui pourrait y être inscrit, puis collez celui correspondant à votre version de Joomla! (voir ci-dessous).

Pour Joomla 1.5, si vous avez modifié le préfixe des tables remplacez le préfixe jos par le votre. Si vous n'avez rien modifié, ne changez rien.

Pour Joomla 1.6, 1.7 et 2.5, le préfixe des tables a été choisi aléatoirement lors de votre installation. Vous devez donc modifier le préfixe jos par le votre. Dans cet exemple, le préfixe est pu5hb :

ajouter-admin3

Une fois que vous avez apporté les modifications nécessaires, cliquez sur le bouton "exécuter".

Vous pouvez maintenant vous connecter à l'administration de votre site avec l'identifiant "admin2" et le mot de passe "secret".

Vous devez impérativement modifier ces identifiants une fois que vous serez connecté.

Attention!  Vous devez impérativement modifier ces identifiants une fois que vous serez connecté.

 

Code :

 compat 15

INSERT INTO `jos_users`
   (`id`, `name`, `username`, `password`, `usertype`, `gid`, `params`)
VALUES (LAST_INSERT_ID(), 'Administrator2', 'admin2',
    'd2064d358136996bd22421584a7cb33e:trd7TvKHx6dMeoMmBVxYmg0vuXEA4199',
    'Super Administrator', 25, '');
INSERT INTO `jos_core_acl_aro`
VALUES (NULL, 'users', LAST_INSERT_ID(), 0, 'Administrator2', 0);
INSERT INTO `jos_core_acl_groups_aro_map`
VALUES (25, '', LAST_INSERT_ID());

 


 

compat 16compat 17compat 25

INSERT INTO `jos_users`
   (`id`,`name`, `username`, `password`, `params`)
VALUES (LAST_INSERT_ID(),'Administrator2', 'admin2',
    'd2064d358136996bd22421584a7cb33e:trd7TvKHx6dMeoMmBVxYmg0vuXEA4199', '');
INSERT INTO `jos_user_usergroup_map` (`user_id`,`group_id`)
VALUES (LAST_INSERT_ID(),'8');
Notez cet article:
1
Proposition d'un évènement depuis le frontend avec...
Séparation ACL de la vision et de l'action sur un ...

Articles en relation

Commentaires 10

 
Guest - Jp Cael le mardi 22 mai 2012 19:51

Bonjour,
j'ai fait rajouté administrator2. et admin2

mais je n'arrive toujours pas à me connecter.

j'ai toujours un écran blanc

Bonjour, j'ai fait rajouté administrator2. et admin2 mais je n'arrive toujours pas à me connecter. j'ai toujours un écran blanc
Simon le mardi 22 mai 2012 20:02

Bonjour,
pourtant c'est bien admin2
Quelle version de Joomla! utilises tu ?

Bonjour, pourtant c'est bien admin2 Quelle version de Joomla! utilises tu ?
Guest - Helene5152 le lundi 23 juillet 2012 13:58

Bonjour,
Je rencontre le même probleme que JP Cael, j'ai suivi les instruction ci dessus, cela m'a bien créé un nouvel utilisateur, mais quand je me connecte, j'ai bien le panneau d'administration qui s'ouvre, mais il est vide et les deux seuls "liens" cliquables que j'ai c'est "voir le site" et "deconnexion"
Je ne sais pas ce que j'ai trafiqué avec les droits des mes user.
Je suis sous joomla 2.5, hebergé chez Gandi
D'avance merci de votre aide

Bonjour, Je rencontre le même probleme que JP Cael, j'ai suivi les instruction ci dessus, cela m'a bien créé un nouvel utilisateur, mais quand je me connecte, j'ai bien le panneau d'administration qui s'ouvre, mais il est vide et les deux seuls "liens" cliquables que j'ai c'est "voir le site" et "deconnexion" Je ne sais pas ce que j'ai trafiqué avec les droits des mes user. Je suis sous joomla 2.5, hebergé chez Gandi D'avance merci de votre aide
Guest - pereto le mercredi 22 août 2012 09:15

Bonjour, ayant par mégarde supprimé le super user dans mon admin, j'essaie de recréer un utilisateur comme vous décrivez au-dessus, ça ne marche pas. Est-ce du au fait que je l'ai "supprimé"dans l'admin auparavant ?
j'ai essayé aussi de placer la requête directement dans la table xxx_users (sous joomla2.5) quelqu'un peut-il m'aider un peu perdue dans phpadmin,

merci pour votre aide

Bonjour, ayant par mégarde supprimé le super user dans mon admin, j'essaie de recréer un utilisateur comme vous décrivez au-dessus, ça ne marche pas. Est-ce du au fait que je l'ai "supprimé"dans l'admin auparavant ? j'ai essayé aussi de placer la requête directement dans la table xxx_users (sous joomla2.5) quelqu'un peut-il m'aider un peu perdue dans phpadmin, merci pour votre aide
Simon le mercredi 22 août 2012 14:19

@ pereto
Aurais tu modifié les droits (ACL) des Super Admins ?

@ pereto Aurais tu modifié les droits (ACL) des Super Admins ?
CptBeaujol le jeudi 20 août 2015 14:25

Génial, ça fonctionne aussi en Joomla 3.4

Merci de m'avoir sauvé la vie....

Génial, ça fonctionne aussi en Joomla 3.4 Merci de m'avoir sauvé la vie....
GraphiqueDesign le samedi 29 août 2015 21:28

Je viens de tenter l'expérience sur un Joomla3 mais avec admin2 et secret cela ne marche pas.
Sinon, j'ai bien respecté la démarche.

Alerte
Le nom d'utilisateur ne correspond pas au mot de passe, ou vous n'avez pas encore de compte.

Je viens de tenter l'expérience sur un Joomla3 mais avec admin2 et secret cela ne marche pas. Sinon, j'ai bien respecté la démarche. [b]Alerte Le nom d'utilisateur ne correspond pas au mot de passe, ou vous n'avez pas encore de compte.[/b]
serge le mercredi 20 janvier 2016 13:51

le texte à mettre dans le mot de passe pour avoir "secret " est : 5ebe2294ecd0e0f08eab7690d2a6ee69
sinon, autre solution, vous modifiez l'utilisateur : dans le mot de passe vous le mettez en clair, et vous le mettez en MD5, puis sauvegardez.

le texte à mettre dans le mot de passe pour avoir "secret " est : 5ebe2294ecd0e0f08eab7690d2a6ee69 sinon, autre solution, vous modifiez l'utilisateur : dans le mot de passe vous le mettez en clair, et vous le mettez en MD5, puis sauvegardez.
ofadis le dimanche 6 mars 2016 11:03

Bonjour j'ai une question un peu similaire.
Lorsque j'essaie de me connecter à mon admin le site me renvoi systématiquement à la page de connexion de l'admin.
Si je tape un faux users là j'ai un message d'erreur.
J'ai trouvé mon user dans la table donc il existe.
Pourquoi alors je ne peux pas accéder à la partie admin de mon site?
merci d'avance car je suis dans la galère

Bonjour j'ai une question un peu similaire. Lorsque j'essaie de me connecter à mon admin le site me renvoi systématiquement à la page de connexion de l'admin. Si je tape un faux users là j'ai un message d'erreur. J'ai trouvé mon user dans la table donc il existe. Pourquoi alors je ne peux pas accéder à la partie admin de mon site? merci d'avance car je suis dans la galère
Simon le dimanche 6 mars 2016 12:50

Bonjour,

afin de pouvoir trouver la cause du problème, merci d'ouvrir un post sur le forum en y donnant un maximum d'information :
http://cinnk.com/forum

Bonjour, afin de pouvoir trouver la cause du problème, merci d'ouvrir un post sur le forum en y donnant un maximum d'information : http://cinnk.com/forum
Déjà inscrit ? Connectez-vous ici
Guest
mardi 25 juillet 2017
Si vous souhaitez vous inscrire, veuillez saisir un nom d'utilisateur, mot de passe et nom.

Image Captcha

Sur ce site, nous utilisons des cookies.